3D Regions Analysis


#1

Hi, I’m wondering if there are any ways to crop out a region in XZ plane. Fiji apparently has Crop (3D) but that only allows a rectangular region. Basically, the green boxes is what I’m trying to crop out after selecting and cropping the yellow box in XY.


#2

Hi Freddy,

Are you planning on analysing these green boxes in PickCells?

I’m not sure how you can directly crop out regions of an image in PickCells, however it does allow you to select desired regions to analyse various features (volume, sum/mean intensity, compactness, etc).

The icon allows you to create ‘colonies’ based on intensity (which would most likely identify your entire embryo as one colony). Then you could compute the colony features via this icon . After this is done, you could go into segmentation editor () of which you could freely edit the colony(ies). In your case, it would be splitting the colony by selecting (drawing) the region of interest.


#3

Hi @fredwck,
I assume you wish to crop these regions in order to group the cells which are within each box and then be able to compare their properties.
You can definitely use PickCells to do this, not by cropping images but by painting the regions using the segmentation editor and then creating the appropriate relationships and filters. I’ll explain…

I’ll assume that you already know how to import images and generate nuclei from segmentation results. If not let me know.

  • First we need to generate empty images with the exact same dimensions as the your original images. Go to File and then click on ‘Generate Canvas’. You will be asked to enter a prefix which will be used to name your images on the file system. Once done, you should be able to find SegmentationResults with a name which contain the prefix you entered (I have used ‘domain’ in the example below)

Just right click on the node to open the contextual menu and select Table Set.

  • Next we can ‘paint’ our newly created canvas using the Segmentation Editor

(Here I 'll put a video in the future but it is too big I need to change the settings in the website to enable larger files you can still find the video ‘3D_Painting’ in the owncloud repo)

  • Once this is done you need to transform your painted domains into actual objects. To do this run ‘Intrinsic Features’ . NB: you can give it a custom type by choosing ‘custom type’ and providing a name which makes sense to you.

  • Now we will create a relationships between nuclei and the newly created objects (which I chose to call ‘Domains’). Run the Membership finder module and select Nucleus as source and ‘Domain’ as target. Once this is done you will see the MetaModel being updated with the new relation:

  • Almost there…, you can now create a new Attribute for your nuclei which will allow to distinguish which domain they belong to. To do so, go to Data>new Attribute

Basically what we do here is get the database id of the domain the nucleus is attached to. I hope this makes sense.

  • Finally you can query your nuclei by grouping them based on the value of this new attribute to obtain visualisations such as the ones below:

The query for the 3D view:

And the query for the Scatter plot:

I hope this all makes sense!


#4

Thanks! I’ve been following that workflow up until Instrinsic Features which gave me a no such element exception error.

I have painted and saved.

Error

Message:
java.util.NoSuchElementException
Level:
WARNING
Stack Trace:
null
java.util.concurrent.ConcurrentHashMap$ValueIterator.next(Unknown Source)
org.pickcellslab.pickcells.impl.providers.PickCellSegmentationProvider.getAnyItem(PickCellSegmentationProvider.java:202)
org.pickcellslab.pickcells.features.FeatureComputerManager.launch(FeatureComputerManager.java:316)
org.pickcellslab.pickcells.main.Workbench.lambda$null$4(Workbench.java:308)
java.lang.Thread.run(Unknown Source)


#5

Hi @fredwck,

I am not sure why this error occurs. It looks as if there are no objects in your painted image.
If you reopen the painted image in the editor, can you see the object you painted previously?
If not, make sure you hit the ‘save’ button before exiting the editor.

If this is not the problem, can you try running the Intrinsic Feature module again but with the Basic Features opened only (close the other envelopes).
If the Intrinsic Feature module modified the MetaModel the last time you used it if you can see a colony node in the view), you will need to delete the objects it created ( right click on the colony node and click 'delete instances, also delete the ‘Associated Object’ key from SegmentationResult Node).

If you still get this error, let me know.

guillaume


#6

Hi @Ghiomm, I think there is a save issue.

As you said, when reopening, I can’t see the object painted previously. I’ve defo clicked the ‘save’ button which opened a progress bar briefly etc.

Just want to confirm, I imported the Col_x.tif (RGBs) and Nuclei_Segmentation_x.tif (32-bit) after doing MultiCellPrepare plugin right?

Furthermore, I tried to import all the Col_ tifs together and I get this error:

The following inconsistencies have been identified:

  • Calibration

They should definitely have the same channel number and bit depth… what is calibration?


#7

Hi @fredwck,

when reopening, I can’t see the object painted previously

Are you using windows, I only tested the system on Linux. Let me know if you see this problem with windows, I’ll try to reproduce the issue as soon as I find some time and come back to you.

Just want to confirm, I imported the Col_x.tif (RGBs) and Nuclei_Segmentation_x.tif (32-bit) after doing MultiCellPrepare plugin right?

You don’t need to use the old plugin anymore, you can directly import your original image directly via Files > Import > Images and then your segmented image via Files > Import > Segmentation Results.

Regarding the ‘calibration’ problem, this tells you that the images you want to import have different voxel sizes. PickCells will not allow you to compare images with different resolutions within the same experiment. Before importing your images you can check the calibration in Fiji (image > properties or ctrl+shift+P).


#8

Are you using windows, I only tested the system on Linux. Let me know if you see this problem with windows, I’ll try to reproduce the issue as soon as I find some time and come back to you.

Yes I’m using Win 10. I’m seeing this problem with Windows and I don’t have a Linux system handy.


#9

Hi @fredwck,
I just tested the painting on Windows 10 and it works fine on my machine. Before saving, do you ‘validate’ the painted area by pressing ctrl+v ? The outline of the painted area should appear, if you save without validating nothing is saved.